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You will Learn: 
• General tips and tricks in navigation, filtering, and 

selection
– Keep input data types
– Keep headers visible as you scroll
– Keyboard navigation shortcuts
– Quickly identify patterns within a column
– Split items within single column
– Highlight cells by their values

• Using formulas to work with data
• Merge multiple tables with vlookup
• Summarize data with PivotTable
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Problem: Excel changes my input data
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Month: JAN to DEC

a number contains leading zeros

a number contains the letter E or
number contains more characters 
than can be displayed 

Note: Copy from HTML page: use paste special -> Unicode text
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Solution: Change formatting to "Text"

1. Open file with plain text
2. Before you populate the data into Excel, select the cells that 

will contain the gene symbols, right-click and choose Format 
Cells >Text > OK

3. Copy and paste data
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Sort & Filter button: Easy to spot patterns
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• Temporarily hide repetitive elements
• Sort the rest of the elements in order

Sort & Filter
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Problem: End of cell contents is missing
Solution: Wrap text
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Split items within single column: 
example 1
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Text to Columns
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Split items within single column: 
example 2
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Text to Columns 
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Merge multiple columns
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Keep headers visible as you scroll
• Choose View > Freeze Panes -> Freeze top Row
• To unfreeze frozen rows, choose View >  Freeze Panes > Unfreeze Panes

10

Freeze both row and column
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Keyboard navigation shortcuts

PC MAC
First cell in the active column Control/Ctrl Up arrow Command
Last cell in the active column Control/Ctrl Down arrow Command
First cell in the active row Control/Ctrl Left arrow Command
Last cell in the active row Control/Ctrl Right arrow Command
The very first cell (A1) Control/Ctrl Home Control/Ctrl
Bottom right corner Control/Ctrl End Control/Ctrl
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plus

plus
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Keyboard selection shortcuts

• Selecting a large range of cells can be a pain.  Here’s 
one trick that could help.
– To start the selection of a large matrix, start by selecting 

the bottom right cell of the desired matrix (Ctrl + End)
– Use "Ctrl + Shift + up arrow" to select everything above 

the original cell. 
– Use "Ctrl + Shift + left arrow" to select everything to the 

left of the original cell. 
– Use "Shift + down arrow" to move down one row (to avoid 

the header line, if present). 
– Use "Shift + right arrow" to move to the right one column 

(to avoid any ID column(s), if present)
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The Cancer Genome Atlas (TCGA)

• NCI / NHGRI project to molecularly characterize
– Over 20k primary cancer samples
– Matched normal samples
– 33 cancer types

• Genomic, epigenomic, transcriptomic, and 
proteomic assays

• Data we’ll use for exercises: 
– Small subset of BRCA RNA-seq data from TCGA
– Unit: normalized gene expression levels
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TCGA barcode IDs
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Unique patient ID

https://docs.gdc.cancer.gov/Encyclopedia/pages/TCGA_Barcode/
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TCGA Sample codes
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Code Definition Short Letter Code
01 Primary Solid Tumor TP
02 Recurrent Solid Tumor TR

03 Primary Blood Derived Cancer -
Peripheral Blood

TB

04 Recurrent Blood Derived Cancer -
Bone Marrow

TRBM

05 Additional - New Primary TAP
06 Metastatic TM
07 Additional Metastatic TAM

08 Human Tumor Original Cells THOC

09
Primary Blood Derived Cancer -
Bone Marrow

TBM

10 Blood Derived Normal NB

11 Solid Tissue Normal NT
12 Buccal Cell Normal NBC

13 EBV Immortalized Normal NEBV

14 Bone Marrow Normal NBM

15 sample type 15 15SH
16 sample type 16 16SH
20 Control Analyte CELLC

Complete sample codes can be found at:  
https://gdc.cancer.gov/resources-tcga-users/tcga-code-tables/sample-type-codes
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Ex.1 (TCGA_data.xlsx)
• Freeze the portion of the sheet BRCA_from_TCGA, so you can always see 

the column names  (TCGA barcodes) and gene names no matter how you 
scroll. 
– hint: View ->Freeze panes / Freeze Top Row

• Split the TCGA barcodes and check the sample codes. How many sample 
types? 
– hint: copy and paste barcodes to another sheet with Paste special -> 

Transpose, then split barcodes with Data -> Text to Columns -> View sample 
codes by turning on Sort & Filter button under Home panel)

• Replace sample barcodes with meaningful names: 
– 01 -> Primary
– 06 -> Metastasis
– 11 -> Normal

• Add sample codes as additional row to top of the BRCA_from_TCGA sheet. 
– hint: Copy -> Paste special -> Transpose

• Sort the samples by sample codes
– hint: Data -> Sort -> Options -> Sort left to right
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https://docs.gdc.cancer.gov/Encyclopedia/pages/TCGA_Barcode/
https://gdc.cancer.gov/resources-tcga-users/tcga-code-tables/sample-type-codes
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Math formulas

– Absolute value:
=ABS(B4)

– Average: 
=AVERAGE(B4:D4)

– Log2 ratio:  
=LOG((O4+1)/(Q4+1),2)

17

Add pseudocount 1 to avoid denominator being 0
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Statistics Formulas

• Example: T test:
=TTEST(B4:D4, I4:N4, 2, 3)
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Logical formulas
• Examples:
– If, else 

=IF( U4<0.05, 1, 0)

– and or
=IF ( AND (T4<0.05,  R4>=1 ), ”yes”, ”no”)
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False

True
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Formula details

• Begin with equal sign: =
• Dollar sign ($): absolute cell references
• Convert formula to real value:
– Copy → Paste Special → Values
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Apply formula to multiple rows at once
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1. Copy equation
(optional)

3. Double clicks

2. Arrow appear

Note:  double check several cells to make sure
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Remove extra spaces within a cell
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How to get an unique list of items within a field? 
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Methods
Sort & 
Filter

Data -> 
Remove 

Duplicates

Is output list in sorted order? Yes No

Can the list be saved? No Yes

Can all items in a super long list be displayed? No Yes
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Color cells with Conditional Formatting
Example 1

24
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Color cells with Conditional Formatting
Example 2
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Highlight extreme values: Color Scales 
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Color cells with Conditional Formatting
Example 3

Highlight extreme values: Color Scales -> 
More Rules 
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Top/bottom
MAC:
Excel version 16:
It’s “Top/Bottom Rules”
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Ex.2 (TCGA_data.xlsx)
1. Drop genes with no expression in all samples

1) Hint: Create another column and name it as “Max” -> use formula to calculate maximum value 
for each gene -> Sort data by “Max” 

2) How do you easily find out where the non-zero value start?
Hint: 

a) Convert values in “Max” column from formula format to value with Copy -> Paste Special -> Values
b) After sorting, with Sort & Filter button to find out the value right above 0 -> Search for this value under “Max” 

column

2. Compare primary tumor vs normal, and metastatic cancer vs primary tumor:
1. Convert values to log2 format:

1) To avoid dividing by 0, you can add 1 to each value
2) Start to get the log2 expression for the top gene in the first patient sample, use our tricks ( see slides) 

to fill out the rest of the cells
2. Calculate log2 average for each gene in normal samples, and do the same for primary tumor 

and metastasis samples.
3. Calculate log2 fold changes (log2FC) between primary tumor and normal, and between 

metastatic cancer and primary tumor, and highlight the log2FC with Conditional Formatting 
4. Calculate p-values with ttest, delete the genes with no valid pvalues, find out FDR adjusted p-

value with the BaRC web tool ( http://bioinfo.wi.mit.edu/bio/tools/fdr/ ), and highlight FDR 
adjusted p-values < 0.05 with Conditional Formatting.

3. We consider a gene is “differentially expressed” if meeting the cutoffs (FDR adjusted 
p-value < 0.05 + at least 2 fold difference). Add two columns named as Sig(PvsN) 
and “Sig(MvsP)”,  fill in with “y” and “n” to indicate if a gene is “differentially 
expressed” or not. 

Hint:  with “if” plus “and”  formula 27
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Lookup and retrieve data

28

Too complicated? 
Try BaRC Submatrix Selector
http://bioinfo.wi.mit.edu/bio/tools/submatrix_selector/

1 2 3

1

28

http://bioinfo.wi.mit.edu/bio/tools/fdr/
http://bioinfo.wi.mit.edu/bio/tools/submatrix_selector/
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Look up values in data list: vlookup
• VLOOKUP(lookup_value,table_array,col_index_num,ran

ge_lookup)
– lookup_value :The value to search in the first column of the 

table array
– table_array:  The table to search (containing the value to search 

for in the first column) 
• Note: use “$” to fix the table

– col_index_num: the column number from which the matching 
value is returned 

– range_lookup:
• True/omitted, an exact/approximate match
• False: an exact match

29
Dollar sign ($): absolute cell references
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Ex.3 (TCGA_data.xlsx)
1. Extract gene symbols from the cells under column “Hybridization 

REF”.  How do you check gene symbols to make sure none of them 
is converted to date format?
Hint:  
Copy cells in this column and Paste them next to the rightest column -> 
use “Text to Columns” to split cells

2. Use vlookup to get the expression levels of a list of genes, such as 
genes in the KEGG_ECM_RECEPTOR_INTERACTION gene set from 
Broad's MSigDB. 

3. Are any of these genes "differentially expressed" as defined by 
1) adjusted p-value < 0.05
2) absolute log2 fold change >= 1
Hint: Use “Sort & Filter” button to quickly narrow down the genes
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Summarize data with PivotTable
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Insert

PivotTable

In this example, it grouped the values by gene and calculated the average
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Pooled CRISPR screening

• Simultaneous targets of a large number of 
genes or regulatory elements.

• To prevent off-target, library includes 
multiple single guide RNAs (sgRNAs) for 
each gene.

• The entire cellular population is subjected 
to selective pressure.

• The genes driving the phenotype of 
interest are identified by comparing the 
relative abundance of corresponding 
sgRNAs in both fractions.

32

Anal Biochem. 2017 532:95

32

https://www.gsea-msigdb.org/gsea/index.jsp
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Ex.4 (CRISPR_data.xlsx)

• CRISPR_data.xlsx includes the percentage of 
guide RNA expression in a subset of a pseudo 
pooled CRISPR screen experiment. Each gene 
has 4 single guide RNAs.

• Could you calculate the percentage of 
expression at gene level with PivotTable?  You 
can summarize expression of the sgRNAs by 
taking their average percentage. 
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• Next Hot Topics:
– Enrichment Analysis - January 28 

• List of Winter/Spring Hot Topics Sessions:
– http://barc.wi.mit.edu/education/hot_topics/upc

oming/
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