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You will Learn:

e General tips and tricks in navigation, filtering, and
selection
— Keep input data types
— Keep headers visible as you scroll
— Keyboard navigation shortcuts
— Quickly identify patterns within a column
— Split items within single column
— Highlight cells by their values

e Using formulas to work with data
* Merge multiple tables with vlookup

Problem: Excel changes my input data

Month: JAN to DEC Al = - % 1D S |
\ 1 |ID Default format
a number contains the letter E or L'SEPZ 2—Sep
than can be dsplayes - ——1572310009E 13 2.31E+19
1410223345 223345
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a number contains leading zeros

Note: Copy from HTML page: use paste special -> Unicode text 3

Solution: Change formatting to "Text"

Open file with plain text

Before you populate the data into Excel, select the cells that
will contain the gene symbols, right-click and choose Format
Cells >Text > OK e —
3. Copy and paste data | I
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Sort & Filter button: Easy to spot patterns

e Temporarily hide repetitive elements

e Sort the rest of the elements in order
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Problem: End of cell contents is missing
Solution: Wrap text

BB Bookl
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A B Cc
|Feature ¥ |baseMe¢ v | log2(YR »

A1BG 119.197 -1.71749
ALCF 0 NA

A2BP1 0.391003 -0.04676
A2LD1 23.8847 -0.25628

&) Bookl

A B C

Feature.l baseMea logZ(YR!/

1D [*]n [v]cev) [+
2 A1BG 119.197 -1.71749
3 AICF 0 NA

4 A2BP1  0.391003 -0.04676
5 A2D1 23.8847 -0.25628

Format Cells
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Split items within single column:
example 1

Text to Columns

Flah

oo Drgobeation =
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Al . 15 TCGA-AB-ADTE) Convert Teut b Colurmms Witeed - Step 2 of 3
2 Tl o —
1 = " < e tekow ki
1 [TCGA-AS-ADTS-01A-11R-ADOZ-07
2 |TCGA-AS-ACES-01A-11R-A002-07 Oty
1 | TUGA-AB-AOSP-01A-11R-A002-07 e
4 |TOGA-AS-ADS4-01A-11R-A002-07 p— [ ——
5 | TCBAAD-AD30-0LA-11R-A002-07 Corra -
£ |TCEA-AZ-ADHS-O1A-31R-A034-07 e T e =
7 [TCGA-A2-ADIQ-DIA-21R-AD3-07 D e
B | TCEAAZ-ADHT-01A-21R-A034-07
% |TCGA-AZ-ADHV-D1A-21R-A034-07
10 | TCGA-AN-ADS1-01A-11R-AD34-07 [—
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M1
A B c 1]
1 |TCGA A8 AD78 014
2 TCGA AS ADSB 014
3 TCGA AR ADBP Q1A
4 TCGA AB ADS4 Q1A
5 TCGA AQ ADID D1A
6 TCGA AT ADMP 01
7 Tcea Ax Asen oA
B TCGA A AT 0L
9 TCGA A ADAV 014
10 TCGA AN ADA1  O1A
AN
AN
AN
AN
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Split items within single column:
example 2

[ A
Viszaafseent 57190
15779/ 5EPPL| 8414
15720{SEPSECS | 51091
15731 [SEFTI0[152001
15712/ SEPT11|55752
15733(SEPTIATIL
15734/ SEPT12 124404
15735
15738
15737}
1573358
15739)

Citemert Tst s Crkerns Wizand - Stip 2 of 3

Thin seomem ety
Errvien ek
Oty
1
Semicsion

Aimat crrasive dekimiters s oo

Corrma

ton guakter TN

e

L
Uemmral corarty marreric v o sumber, date sshoe b datr.
it A e ko ek
e
=
Camm - Ban s
8




Merge multiple columns

1 Data H v ROBA
n
[TTIFrom Table 17 Y T3k
Get Edternal - New Refresh FL Sort  Filter Text
Data*  Query - LoRecent Sources - W Advanced o)y
G e Trashiem s
H1 ¥ fe =CONCATENATE(AL, "-", BL, "-",C1)
A B € D E I 1)
1 |TCGA AB AO7E 01A 11R ADDZ  7|TCGA-AB-ADTB
2 |TCGA A3 ADSE 01A 11R ADDZ  7|TCGA-AB-ADEE
3 |TCGA  AB ADBP  01A 11R  ADDZ  7|TCGA-AB-ADSP
4 |TCGA  AB ADS4 01A 1IR ADDZ  7(TCGA-AB-ADS4
5 |TCGA AOD AD30 O01A 11R ADDZ  7|TCGA-AD-AD3O
6 |TCGA A2 AD4P 01A  31R AD34  7(TOGA-AZ-AD4P
7 |TCGA A2 ADdQ  01A 21R AD34  7ITCGA-AZ-ADACL
8 |TCGA A2 ADAT  01A 21R  A034  7|TCGA-AZ-ADAT
9 |TCGA A2 AD4V D1A 21R AD34  7(TCGA-AZ-ADAV
10 |TCGA AN ADM1 O01A 11R AD34  T|TCGA-AN-AD4L
11 |TCGA AN AD4E  01A 2IR AD34  7(TCGA-AN-ADSG
12 |TCGA AN AD4A D1A 21R AD34  7|TCGA-AN-ADSA
13 |TCGA AN ADMC  01A 21R A034  7(TCGA-AN-ADMC
14 |TCGA AN ADMD 01A 21R AD34  7|TCGA-AN-AD4D

Keep headers visible as you scroll

* Choose View > Freeze Panes -> Freeze top Row
e To unfreeze frozen rows, choose View > Freeze Panes > Unfreeze Panes

Microsoft Exc

_)\/iew Developer Acrobat

f iE.;I _.E' = E X Split
l—} : L% = Hide
m 100% Zoom to Mew  Arrange | Freeze

Selection | Window Al
Zoom

iy

Save
' Waorkspad

Keep rows and columns visible while the rest of
the worksheet scrolls (based on current selection). ||

Zon Freeze Top Row
== Keep the top row visible while scrolling through _@
the rest of the worksheet.

| = Freeze First Column
_L_.lﬂ Keep the first calumn visible while scrolling
CEU_NAO CEU_MNA1 YRI_NAI through the rest of the worksheet,
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Keyboard navigation shortcuts

PC:

— First cell in the active column: Ctrl + up arrow
— Last cell in the active column: Ctrl + down arrow

— First cell in the active row:  Ctrl + left arrow
— Last cell in the active row:  Ctrl + right arrow
— The very first cell (A1): Ctrl+ Home

— Bottom right corner: Ctrl+ End

MAC:
— use either Command or Control
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Keyboard selection shortcuts

» Selecting a large range of cells can be a pain. Here’s
one trick that could help.

— To start the selection of a large matrix, start by selecting
the bottom right cell of the desired matrix (Ctrl + End)

— Use "Ctrl + Shift + up arrow" to select everything above
the original cell.

— Use "Ctrl + Shift + left arrow" to select everything to the
left of the original cell.

— Use "Shift + down arrow" to move down one row (to avoid
the header line, if present).

— Use "Shift + right arrow" to move to the right one column
(to avoid any ID column(s), if present)

12

7 Freeze Panes lle— Freeze both row and column




The Cancer Genome Atlas (TCGA)

TCGA barcode IDs

* NCI / NHGRI project to molecularly characterize
— Over 20k primary cancer samples TSS Sample Portion Cander
— Matched normal samples \ l Plate
— 33 cancer types
* Genomic, epigenomic, transcriptomic, and TC6A-02-0001-01C-01D-0182-01
proteomic assays _ - t
’ . Praject Participant Vial Analyte
* Data we’ll use for exercises: \ |
— Small subset of BRCA RNA-seq data from TCGA |
. . . Unique patient ID
— Unit: normalized gene expression levels
https://docs.gdc.cancer.gov/Encyclopedia/pages/TCGA Barcode/
13 14
TCGA sample codes Ex. 1
Code Definition Short Letter Code
- 01 Primary Solid Tumor P Freeze the portion of the sheet BRCA_from_TCGA, so you can always see
02 Recurrent Solid Tumor TR the column names (TCGA barcodes) and gene names no matter how you
Primary Blood Derived Cancer - scroll.
03 X 8 . .
. Peripheral Blood — hint: View ->Freeze panes
8| 04 Recurrent Blood Derived Cancer - o0/ Split the TCGA barcodes and check the sample codes. How many sample
S | Bone Marrow types?
= | % Additional - New Primary TAP — hint: copy and paste barcodes to another sheet with Paste special ->
g 06 Metastatic ™ Transpose, then split barcodes with Data -> Text to Columns -> View sample
e 07 Additional Metastatic TAM codes by turning on Sort & Filter button under Home panel)
08 Human Tumor Original Cells THOC Replace sample barcodes with meaningful names:
e Primary Blood Derived Cancer - ./ — 01 ->Primary
- Bone Marrow — 06 -> Metastasis
- 10 Blood Derived Normal NB — 11 -> Normal
LL 2ol 3t o i NT Add sample codes as additional row to top of the BRCA_from_TCGA sheet.
= 12 Buccal Cell No_rmal NBC — hint: Copy -> Paste special -> Transpose
I 13 EBV Immortalized Normal NEBV Sort the samples by sample codes
B 14 Bone Marrow Normal NBM ) P Y p. )
= T sample type 15 15SH — hint: Data -> Sort -> Options -> Sort left to right
L 16 sample type 16 16SH
20 Control Analyte CELLC

Complete sample codes can be found at:

15
https://qdc.cancer.qov/resources-tcqga-users/tcqga-code-tables/sample-type-codes ’
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Math formulas

— Absolute value:
=ABS(B4)

— Average:
=AVERAGE(B4:D4)

— Log2 ratio:
=LOG((04+1)/(Q4+1),2)

/

Add 1 to avoid denominator being 0
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Statistics Formulas

e Example: T test:
=TTEST(B4:D4, 14:N4, 2, 3)

]

Tails Required. Specifies the numbgh of distribution tails. If tails = 1, T.TEST uses the one-tailed
distribution. If tails = 2, T.TEST uses jhe two-tailed distribution.

« Type Required. The kind of t-T£st to perform.

Parameters

If type equals

Two-sample equal variance (homoscedastic)

Two-sample unequal variance (heteroscedastic)

18

Logical formulas

Examples:

—If, else

/True
=IF( U4<0.05, 1, Ol\
False

—and or
=IF ( AND (T4<0.05, R4>=1), "yes”, "no”)

\ J
|

19

Formula details

* Begin with equal sign: =
* Dollar sign (S): absolute cell references
* Copy - Paste Special - Values

20




Apply formula to multiple rows at once

Remove extra spaces within a cell

E x o alibi 1n A A = = ¥ Wiap 1 G e W, 3 T e e
o Macopy - = Paste 5-A 3 Mg 8 oo -
i & Format Paiter BIU- ¥ A 2 g = Merge . i
Nig
i % £ Microsoft Excel - Book3
i fi | sL0G{B3+1.2)
h o S T — 3, File  Edit nsert Format Tools Data Window Help  Adobe PDF
A N o pp g R 1 Primary Matastasi Matastasi Matastasi Normal  Nern e - - —
Primary Metastas: Metastasi: Motastasi: Nor Toser TEA R T H- TOR L [TCEA 8T DEEHR S RTE 5 S0 o8 = s A a2 =@ z10 | B L U
TCGA-E2- TCGA-BH- TCGAEZ- TCGAE- TCC i R oo P et s -
ALIV-01A ALBV-D6A- A1SE-O6A- A15K-D6A- ALE 2 Hybridization REF - [A1200 - Max - 07 A1D0- 07 - |a1200- AL B1 S % =TRIM(AT)
11R- 11R-A213-11R- 11R-A12P-118 I - 1 |pTPMz0a 553129 0 00728 0101112 [} % -
Hybridization REF - |A120-0 - Max (=107 - |a12D-0-107 -l COPY eq‘uatloh CTasa2|728911 o 01857 L] 0 o A B
|pren20A 653129 0 0.0726) 0.101112 0 . (optional} |crasasjsaiszo o 01857 0 o o
CT45A2| 728911 0 01657 # [SNDRAS|615568 0 02651 ] ° o H H
' . 7 o omi 8 o g 1 |Please getrid of extra spaces |Please get rid of extra spaces
CTd5A4| 431520 0 01687 2. Arrow appear : |
SNORA4|619568 0 Daes . B (4021241375318 0 0.2904 0367818 o o
B S T 4 [c190rf75 284380 U 0.2904 036THIE o o 2
e 2 . [0caene| 15218 0 0.2004) 0367818 0 0
AQP124|375318 0 02904 3. Double glicks 11 |crortzs| z028ss 0 D.2904) 0367818 ) o 3
Cl3orf15| 284369 0 02904 17 [caa|731 0 02904 0367818 [ L
| | ClorfT9]152118 0 02904 13 |CCDC105| 126402 0 0.2904) 0367818 o o 4
Clorf33| 202865 0 0.2904 14 |CLECIB 51268 0 0.2004) 0367818 o o
€84731 o 02904 15 |DEFAa| 1685 U 0.2904) 0367818 0 o
16 | DMATEY 53928 0 02904| 0367818 L o
CORCDS Laacs ;gm0 17 |DPPAs| 340168 0 02904 0367818 L of
CLECLS L ) 18 |ORO3| 1814 0 0.2504| 0367818 a 0',
| DEFA4| 1669 o 02904 19 [GDe7| 151449 0 0.2504| 0367818 2 o
| DMATB1|63948 0 0.2904 20 |LCE3E | 353145 0 02504 0367818 o o
OPPAS| 340168 0 02904 1 |Loczs3gss| 283999 o 02904 0367815 o oj~
| DRD3|1814 0 0.2904 | BRCA fram TEGA | Sheetl | KEGG ECM_RECEPTOR INTERACTICH “
| GDF7|151449 0 02904 -ty B
Note: double check several cells to make sure
21 22
C . e, . .
olor cells with Conditional Formatti ng Color cells with Conditional Formatting
EX xlsx - Excel g g ‘
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98| [E NewRule.. E‘ e 9175395.495 1144637 0.075121 0.533639 e oTLi0s3Ea" 01884 1 nTace RO R
82| [3 Clear Rules b - 24] 5286.836 -4.4375 -1.10172 0.189681¢ 0 33143 0 3.314370.117925 0552363 0 0.473661) 0.63448
Py 4 g g < &9 33143 0 331837 0.1138571.088267° 067365 0.90714) 031831
35 E Manoge Rules... D Duplicate Values... L2001 0509 08717 D672 0 33 0 331437 0961571056517 111 0.069648) 0.085638
. § | M = J 5 31 2156.754 0.090939 -0.47521 0.896235% 0 33143 0 33143 "0.679967  1.01045 0.748433) 0.255086
05 5.6243  30.6551 393.218( 79" 350914 2.315072 -0.01446  0.443796 o 3am LT A 0 0.E3ARSEE0 IR
More Rules... - 5 0 0 09889 3.3581 0504075  0.64965° 168405 0.04943) 0.702252
55| 3491.259| 3314.71) 2496.904 e reurwamr—raverr e 25 3158474 -5.44442 6£.569742 0.0043097 g2 a o 3368170703175 0.1922677 243738 .0.51452 1853788
" " " 846 13257 16481 3.36617 144295°1815183° 243735 0.254962) 023771
23 o 0 13185 336817 1.542875° 021975 20607 -1,08588 1337278 24




Color cells with Conditional
Example 3

Formatting

Highlight extreme values: Color

Scales -> More Rulgs

hut  Formulas  Data Review  View  ACROBAT  Developer

¢ -9, 9 %000 Condiional Fom
B Formatting = Tal
ot smber i
fe .
New Formalting Rule N [
R 5 e cuing e - M =
Select a Rule Type:

= Farmat all cells based on their valisss |

+ Farmat only cells that contain

= Farmat only 1op or bottom ranked values |

= Format only valiues that are sbove or below average
og2(M/P = Format only unique or duplicate values M

- llag2(p/i = |Mvsp ff Lo Use  formua o determine which celsto format s
0.384316| -0.34068| 0.588 Edit the Rute Description:
0.093457{ROFIISS! O Format values that rank in the:
-0.30015) -1.08402] O.

Toy - 10 v % of the selected ra pre—
0.205713| 0.109701) o788 rge €] Top/bottom
-0.97894| -1.33834] 0.1
-0.53919| 2.732735| 0.7 —

Laoz20d R 0 et _ |—E¢'ﬂﬂ— |

0.448461| -0.88095 0. -

0.008764) -D.00214| 0.9 [+13 Cancel 25
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Ex. 2

Drop genes with no expression in all samples

1) Hint: Create another column and name it as “Max” -> use formula to calculate maximum value
for each gene -> Sort data by “Max”

2) How do you easily find out where the non-zero value start?

Hint:
a) Convert values in “Max” column from formula format to value with Copy -> Paste Special -> Values
b) After sorting, with Sort & Filter button to find out the value right above 0 -> Search for this value under “Max”
column
Compare primary tumor vs normal, and metastatic cancer vs primary tumor:
1. Convert values to log2 format:

1) To avoid dividing by 0, you can add 1 to each value

2) Start to get the log2 expression for the top gene in the first patient sample, use our tricks ( see slides)
to fill out the rest of the cells

2. Calculate log2 average for each gene in normal samples, and do the same for primary tumor
and metastasis samples.
3. Calculate log2 fold changes (log2FC) between primary tumor and normal, and between

metastatic cancer and primary tumor, and highlight the log2FC with Conditional Formatting

4. Calculate p-values, find out FDR adjusted p-value with the BaRC web tool
(http://bioinfo.wi.mit.edu/bio/tools/fdr/), and highlight FDR adjusted p-values < 0.05 with
Conditional Formatting.

We consider a gene is “differentially expressed” if meeting the cutoffs (FDR adjusted
p-value < 0.05 + at least 2 fold difference). Add two columns named as Sig(PvsN)
and “Sig(MvsP)”, fill in with “y” and “n” to indicate if a gene is “differentially
expressed” or not.

Hint: with “if” plus “and” formula 2%

Lookup and retrieve data

@_" File Edit View Insert Format Tools Data Window Help Adobe PDF
NEHROS R VE S S P9 o8 2] @ Bive
A g =VLOOKUP($E2 $A52: $C$489,2,FALSE5 >
| B0 | E ) F [ ] [
| 1 |Probe fetal_brain_mean adult_brain_mean Probe fetal brain mean _adult_brain_mean
| 2 |100_g_at 5603044225 7.114704126 1091_at 8.9835086731 11.39205046
| 3 [1039_s_at 7.098027859 5.618848604 1160_at 7.845672366 9.368257073
| 4 |1052_s_at 6.935502676 7.634905024 1039_s_at 7.0980278539 5.818848604
| 5 [1063_s_at 7.177586401 9.29804292
| 6 |1091_at 8.983598873 11.39205046
| 7 [1107_s_at 6.356422623 8.130576734
| 8 |1115_at 3.554644254 3.593192033
| 9 |1160_at 7845672366 9.368257073
10118 _at 2.595289217 8.041784791
111194 _g_at 5.287191623 1.79435423
| 121232 s_at 4.275895519 4.241452629
131247 _g_at 5.938234238 3.684240951
| 14 1264 _at 4.638605837 3.465669364
151271 _g_at 7.456925352 7.19580788
| 16 1346 _at 8.146894113 12.06442416

Too complicated?
Try BaRC Submatrix Selector

http://bioinfo.wi.mit.edu/bio/tools/submatrix_selector/
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Look up values in data list: viookup

* VLOOKUP(lookup_value,table_array,col_index_num,ran

ge_lookup)

— lookup_value :The value to search in the first column of the
table array

— table_array: The table to search (containing the value to search
for in the first column)

* Note: use “S” to fix the table

— col_index_num: the column number from which the matching
value is returned

— range_lookup:
* True/omitted, an exact/approximate match
¢ False: an exact match

Dollar sign (S): absolute cell references
28




Ex.3

Extract gene symbols from the cells under column “Hybridization
REF”. How do you check gene symbols to make sure none of them
is converted to data format?

Hint:

Copy cells in this column and Paste them next to the rightest column ->
use “Text to Columns” to split cells

Use vlookup to get the expression levels of a list of genes, such as
genes in the KEGG_ECM_RECEPTOR_INTERACTION gene set from
Broad's MSigDB.

Are any of these genes "differentially expressed" as defined by
1)  adjusted p-value < 0.05

2) absolute log2 fold change >=1

Hint: Use “Sort & Filter” button to quickly narrow down the genes

29
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