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You will Learn:

* General tips and tricks in navigation, filtering, and
selection
— Keep input data types
— Keep headers visible as you scroll
— Keyboard navigation shortcuts
— Quickly identify patterns within a column
— Split items within single column
— Highlight cells by their values

* Using formulas to work with data
* Merge multiple tables with vliookup



Problem: Excel changes my input data

Month: JAN to DEC Al = R & ID | . |
\; ID |Default format

a number contains the letter E or » | SEP2 2-Sep

[‘h”arﬁi‘i;ncﬁztz‘:;‘;.;“y‘;f characters L ->2310009E13 2.31E+19

4 C<23345 223345

a number contains leading zeros

Note: Copy from HTML page: use paste special -> Unicode text 3
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Solution: Change formatting to "Text"

Open file with plain text
Before you populate the data into Excel, select the cells that
will contain the gene symbols, rlght cllck and choose Format
Cells >Text > OK ErETE
Copy and paste data =1se = wew ween roms o o
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ort & Filter button: Easy to spot patterns

 Temporarily hide repetitive elements
e Sort the rest of the elements in order

Sort & Filter

Insert Page Layout Formulas Developer Acrobat
% cut _ =; . *j 7 7 T ’j I AutoSunf -
23 Copy - Calibri = Wrap Text General ﬂ % _’_;‘d ==) - E il -
Foste o Format painter | B £ U~ B mergem center - | § - % | T SR | Lo o s | o Do PO | G Crear
Clipboard = Font Fl Alignment ] Mumber Fl Styles Cells
Al - Je | Feature.lD
=] DESeq2.out.Fulltct
[ 4] A B C D 3 ; G H 1 ] K L M N 0 P aQ R s
| 1 |Feature.|[] ~ IbaseMe = | log2(YR ~ | IfcSE |~ |stat w | pvalue| v padj |~|CEU_N4~|CEU_Ns~ |YRI_NA ~ |YRI_NA = |CEU_N4~ CEU_MN/~ | YRI_NA ~ |YRI_NA v |CEU N4~ |CEU_N{~ |YRI_NA = | YRI_NA ]
74 SortAtoZ 119.197 -L.71743 0.365668 -4.67696 2.91E-06 0.000354 236 312 34 21 160.74 243.99 39.2 32.86 6.98 7.33 6.03 5.9
2] sonzten 0 NA MNA NA NA MA 0 0 0 0 ] ] 0 0 0 0 ]
Sort by Color » | 0.391003 -0.04676 0.125607 -0.33845 0.735027 NA 0 2 0 o 0 1.56 0 0 -1.09 -L.07 -1.09 -1.0
. 23.8847 -0.25628 0.390625 -0.66022 0.509112 0.824137 36 43 8 13 24,52 33.63 9.22 28.17 4.56 4.67 4.33 4.
. 10.2322 0.321001 0.30687 1.11826 0.263457 0.649452 9 3 1 20 6.13 2.35 115 313 3.08 3 2.98 3.41
1.46147 -0.00963 0.171605 -0.05646 0.954972 NA 0 4 1 1 0 3.13 115 1.56 0.5 0.56 0.53 0.5
Text Eilters ' 591.392 -0.25942 0.335129 -0.79365 0427401 0.77935 208 1911 178 335 141.67 1454.41 205.21  524.27 771 10.02 8.03 8.9
Search (All) ,D|Z| 0 NA NA NA NA MNA 0 0 0 o 0 0 0 0 o o 0
. | 0.782006 -0.07462 0.127875 -0.54963 0.582575 NA 0 4 o o 0 3.13 0 o -0.37 -0.32 -0.37 -0.3
[ 384.481 0.4696384 0.314927 1.49144 0.135846 0.488014 431 413 487 230 293.55 322.97 561.45 359.95 8.32 8.41 8.93 8.5
408.579 -0.53154 0.323797 -1.64102 0.100794 0.425495 731 643 348 146 497.88  506.74 401.2 228.49 8.85 8.86 3.64 8.1
0.391003 -0.04676 0.125607 -0.33845 0.735027 NA o 2 o o 0 1.56 0 o -1.09 -1.07 -1.09 -1.0
0.195502 -0.014 0.124404 -0.12732 0.393691 NA 0 1 0 o 0 0.78 0 0 -1.74 -1.73 -1.74 -1.74
0 NA NA NA NA NA 0 0 o o 0 0 0 o o o 0
0.391003 -0.04676 0.125607 -0.33845 0.735027 NA 0 2 o o 0 1.56 0 o -1.09 -L07 -1.09 -1.0




Problem: End of cell contents is missing

&) Bookl

A B C
1 AFeaturei v| baseM{ v IogZ(Yﬁ v
2 AI1BG 119.197 -1.71749
3 AICF 0 NA
4 A2BP1 0.391003 -0.04676
5 A2LD1 23.8847 -0.25628

> Format Cells

Solution: Wrap text

Number ( Alignment
Text alignme!
Horizontal:

| General

Vertical:
Bottom
Justify distributed

ext control

[] merge cells
Right-to-eft

Font | Border | Fil | Pf

B Indent:
0
[=]

-
=a

|Z_}] Bookl

A

B | ¢

Feature.l baseMea log2(YRI/

D
A1BG
(AICF

VoA wWwN e

'-v‘n

A2BP1
A2LD1

Lzicev) [~]
119.197 -1.7174S
0 NA
0.391003 -0.04676
23.8847 -0.25628




Split items within single column:
example 1

Text to Columns

H oo -

File Home

Insert Pagelayout Formulas

Book1 - Excel

Review View ACROBAT

Tell me wh.at you want to do...

File

Home

Insert

Page Layout

Formulas

E T Show Queries Connections Y Clear ré I\ FlashFill B+ Consolidate B E =7 Show Queries ||= Connections 4 E
= m From Table Properties Iy E-¥Remove Duplicates Relationships d 5| EF Tabl & Properties 24| A
et Bxternal  New Refresh z| Sort  Filter ’ Text to - What-If Get External rom fable roperties
. il b A Data Validation ~ New Refresh Zl S
Data~  Query~ [‘@) Recent Sources 5 Edit Links Iy Advance  columns Analysis ~ Data~  Query~ [‘@) Recent Sources - Edit Links A
Get & Transform Connections Sort & Filter Data Tools Forec G .
et & Transform Connections
Al - e TCGA-A8-A078]{ Convert Text to Columns Wizard - Step 2 of 3 M H1 £
< x
A B C This screen lets you set the delimiters your data contains. You can see how your text is affected in the L
1 [TCGA-A8-A07B-01A-11R-A002-07 previewbelor A_JmBEC DI E F E :
2 |TCGA-AB-A08B-01A-11R-A00Z-07 Btz ; Egi 2: 22;2 giz 112 232; ;
3 |TCGA-A8-A08P-01A-11R-A00Z-07 Tab
4 |TCGA-A8-A094-01A-11R-A00Z-07 ["] semicolon || Treat consecutive delimiters as one S TCGA |AB |ADBP 01A 11R _|A00Z 7
5 |TCGA-AO-AD30-01A-11R-A00Z-07 [ comma . " 4 |TCGA A8 |A094 01A 11R  |A00Z 7
6 |TCGA-A2-A04P-01A-31R-A034-07 [ space Text gualifier: E 5 TCGA A0 A030 01A 11R  A00Z 7
7 |Tcea-Az-A040-01A-21R-A034-07 otrer. |- 6 TCGA A2 A04P 01A 31R  AD34 7
3 |TCGA-A2-A04T-01A-21R-A034-07 = 7 TCGA A2 A04Q 01A 21R  A034 7
9 |TCGA-A2-A04V-01A-21R-A034-07 8 TCGA A2 A04T 01A 21R  A034 7
10 |TCGA-AN-A041-01A-11R-A034-07 Data preview 9 [TCGA A2 A04Vv  01A 21R  A034 7
11 |TCGA-AN-A046-01A-21R-A034-07 10 TCGA AN A041 01A 11R  A034 7
12 |TCGA-AN-AO4A-01A-21R-A034-07 11 TCGA AN A046 01A 21R  A034 7
CGA B8 078 [0la [L1R ROOZ [07 -
13 [TCGA-AN-A04C-01-21R-A034407 CGA 8 08B [0l [L1R RO00Z 07 B 12 TCGA AN AQ4A 21R  A034 7
CGA B8 08P [01R [L1IR 00z |07 =
14 |TCGA-AN-A04D-01R-21R-A034%07 con ke 004 bia hir kooz o7 13 TCGA AN 21R  A034 7
L5 |TCGA-AO-A03T-01A 7 CGA RO 030 (01a JLIR RO0Z 07 14 ' TCGA 21R  A034 7
CcA B2 04P [012 [1R [R034 [07
L6 |TCGA-AQ-A04J-01A- CGA a2 04Q [p1a [P1R |[n034 07 - 15 TCGA MR A034 7
L7 |TCGA-A7-AOCH-01A-N 4 g 16 TCGA 02R  AO034 7
18 |TCGA-A8-AD6T-01A-11 17 TCGA A7 21R  A00Z 7
19 | TCGA-A8-AO7F-01A-11R- Concel | | <pack | [ Mea> ] Einisn 18 TCGA 11R  A00Z 7
20 [TCGA-A8-A081-01A-11R-A00Y 19 01A 11R A00Z 7




Split items within single column:
example 2

A g A B C

15728|SEPN1|57190 15728|SEPN1 57190
15729(SEPP1|6414 15729|SEPP1 6414
15730|SEPSECS|51091 15730(SEPSECS 51091
15731|SEPT10|151011 15731|SEPT10 151011

15732 (SEPT11 55752

15732(SEPT11|55752

15733|SEPT1]|1731 15733 (SEPT1 1731

15734|SEPT12|124404 157/34(SEPT12 124404
15735(SEPT14|346288 15735|SEPT14 346288
15736|SEPT2]4735 15736|SEPT2 4735
15737|SEPTH| 5596 15/37(SEPT3 55964
15738|SEPT4\3414 15738|SEPT4 5414

157391SEPTS 5413

15739(SEPTS|

Text to Columns

\ ol PWMB 2. |

Convert Text to Columns Wizard - Step 2 of 3

This screen lets you set the delimiters your data contains. You can see how your text is affected in the
preview below.

Delimiters
V| Tab
Semicolon Treat consecutive delimiters as one
Lomma .
Ter quater. TN |
Space
V| Other: ||

Data preview

ybridization REF

1BG L

1CF 9974
2BP1 54715
2LD1 B7769
2M

ZML1 L44568

4 »

mj »

1

Cancel | ‘ < Back ‘ [ Next > ] | Einish

This screen lets you select each column and set the Data Format.
Column data format
General
O frexd
Date: MDY E

Do not import column (skip)

‘General’ converts numeric values to numbers, date values to dates,
and all remaining values to text.

Advanced...

i

Destination: | $AS1

Data preview

m»

Cancel ‘ ‘ < Back




Merge multiple columns

H ©- v B
File Home [Insert Pagelayout Formulas Review View ACROBAT () Tell
|:'>u FD 7 Show Queries ”zn Connec’ltions %l Y Clear
DFrom Table = Properties . Reapply
Get External  New Refresh L z| Sort Filter ) Text
Data~  Query~ [E) Recent Sources  p||~ Edit Links Y/ Advanced q|ur
Get & Transform Connegli ilter
H1 v Jr (( =CONCATENATE(A1,"-", B1, "-", C1)
A B C D J
1 |TCGA A8 A07B 01A 11R AD0Z  7|TCGA-A8-A07B
2 |ITCGA A8 AO8B 01A 11R A00Z  7|TCGA-A8-AD8B
3 |TCGA A8 AO08P 01A 11R A00Z 7|TCGA-A8-A08P
4 |TCGA A8 A094 01A 11R A00Z 7|TCGA-A8-A094
5 |TCGA AO A030 01A 11R A00Z  7|TCGA-AO-AD30
.L 6 |TCGA A2 AO04P 01A  31R A034  7|TCGA-A2-A04P
17 |tcea A2 A04Q 01A 21R A034  7|TCGA-A2-A04Q
, 8 [TCGA A2 A04T 01A 21R A034  7|TCGA-A2-A04AT
9 |TCGA A2 A04V 01A 21R A034  7|TCGA-A2-A04V
10 I[TCGA AN A041 01A 11R AD34  7|TCGA-AN-AD041
11 ITCGA AN AO46 01A 21R A034  7|TCGA-AN-A046
12 ITCGA AN AO4A 01A 21R A034  7|TCGA-AN-AOD4A
13 I[TCGA AN A04C 01A 21R A034  7|TCGA-AN-A04C
14 ITCGA AN A04D 01A 21R A034  7|TCGA-AN-A04D




Keep headers visible as you scroll

Choose View > Freeze Panes -> Freeze top Row
To unfreeze frozen rows, choose View > Freeze Panes > Unfreeze Panes

e cromort xcey ™ —

_.)‘-.Fi W Developer Acrobat

B = HEIR. | fnions | B

m 100% Zoomto Mew  Arrande | Freeze - - Save
Selection | Window  All \ |[Panes = Jninide - k4 Resel dowr FosItio Warkspad

Zoom Freeze Panes le— Freeze both row and column
Keep rows and columns visible while the rest of 1
the worksheet scrolls (based on current selection). ||

Freeze Top Row

= Keep the top row visible while scrolling through _@
g H I 1 the rest of the worksheet.
Freeze First Column
[_l:l Keep the first column visible while scrolling
CEU_MAD CEU_MAL YRI_MAI through the rest of the worksheet.

10



Keyboard navigation shortcuts

PC:

— First cell in the active column: Ctrl + up arrow

— Last cell in the active column: Ctrl + down arrow
— First cell in the active row:  Ctrl + left arrow

— Last cell in the active row:  Ctrl + right arrow

— The very first cell (A1): Ctrl+ Home
— Bottom right corner: Ctrl+ End
MAC:

— use either Command or Control

11



Keyboard selection shortcuts

e Selecting a large range of cells can be a pain. Here’s
one trick that could help.

— To start the selection of a large matrix, start by selecting
the bottom right cell of the desired matrix (Ctrl + End)

— Use "Ctrl + Shift + up arrow" to select everything above
the original cell.

— Use "Ctrl + Shift + left arrow" to select everything to the
left of the original cell.

— Use "Shift + down arrow" to move down one row (to avoid
the header line, if present).

— Use "Shift + right arrow" to move to the right one column
(to avoid any ID column(s), if present)

12



The Cancer Genome Atlas (TCGA)

* NCI/ NHGRI project to molecularly characterize
— Over 20k primary cancer samples
— Matched normal samples
— 33 cancer types

* Genomic, epigenomic, transcriptomic, and
proteomic assays

* Data we’ll use for exercises:
— Small subset of BRCA RNA-seq data from TCGA

— Unit: normalized gene expression levels



TCGA barcode IDs

TSS Sample Partion Center

NN Lo )

TCGA-02-0001-01C-01D-0182-01

1R

Project Farticipant Vial

\ )
f

Unique patient ID

Analyte

https://docs.gdc.cancer.gov/Encyclopedia/pages/TCGA Barcode/

14


https://docs.gdc.cancer.gov/Encyclopedia/pages/TCGA_Barcode/

TCGA sample codes

Code Definition Short Letter Code
- 01 Primary Solid Tumor TP
02 Recurrent Solid Tumor TR
Primary Blood Derived Cancer -
03 PeripthaI Blood T8
g 04 Recurrent Blood Derived Cancer - TRBM
— Bone Marrow
‘O: } 05 Additional - New Primary TAP
g 06 Metastatic ™
E 07 Additional Metastatic TAM
08 Human Tumor Original Cells THOC
09 E:)irr:\eaaalilrc;c\)l\clj Derived Cancer - TBM
- 10 Blood Derived Normal NB
11 Solid Tissue Normal NT
. 12 Buccal Cell Normal NBC
g <4 13 EBV Immortalized Normal NEBV
o) 14 Bone Marrow Normal NBM
= 15 sample type 15 15SH
L 16 sample type 16 16SH
20 Control Analyte CELLC

Complete sample codes can be found at:
https://qdc.cancer.qgov/resources-tcqa-users/tcqga-code-tables/sample-type-codes



https://gdc.cancer.gov/resources-tcga-users/tcga-code-tables/sample-type-codes

Ex. 1

Freeze the portion of the sheet BRCA_from_TCGA, so you can always see
the column names (TCGA barcodes) and gene names no matter how you
scroll.

— hint: View ->Freeze panes
Split the TCGA barcodes and check the sample codes. How many sample
types?

— hint: copy and paste barcodes to another sheet with Paste special ->

Transpose, then split barcodes with Data -> Text to Columns -> View sample
codes by turning on Sort & Filter button under Home panel)

Replace sample barcodes with meaningful names:
— 01 -> Primary
— 06 -> Metastasis
— 11 -> Normal
Add sample codes as additional row to top of the BRCA from_TCGA sheet.
— hint: Copy -> Paste special -> Transpose
Sort the samples by sample codes
— hint: Data -> Sort -> Options -> Sort left to right



Math formulas

— Absolute value:
=ABS(B4)

— Average:
=AVERAGE(B4:D4)

— Log2 ratio:
=LOG((04+1)/(Q4+1),2)

7

Add 1 to avoid denominator being O



Statistics Formulas

* Example: T test:

=TTEST(B4:D4, 14:N4, 2, 3)

]

= Tails Required. Specifies the numbgh of distribution tails. If tails = 1, T.TEST uses the one-tailed

distribution. If tails = 2, T.TEST uses #he two-tailed distribution.

= Type Required. The kind of t-Tfst to perform.

Parameters
If type equals This test is performed
1 Paired
2 Two-sample equal variance (homoscedastic)
3 Two-sample unequal variance (heteroscedastic)

18



Logical formulas

Examples:
— If else True
=IF( U4<0.05, 1, 0)\
False
—and or

=IF ( AND (T4<0.05, R4>=1), "yes”, “no”)

\ }
|




Formula details

* Begin with equal sign: =
* Dollar sign (S): absolute cell references
* Copy — Paste Special - Values



Apply formula to multiple rows at once

Insert

LD ‘K’ cut Calibri

ste E@COPY ) B I U-

| ~ Format Painter =

Clipboard r
; -
A N

Primary
TCGA-E2-
A14V-01A:
11R-

Hybridization REF ~ |A12D-0 ~
|PTPN20A|653129
CT45A2|728911
CT45A4|441520
SNORA4|619568
SNORA44|677825
AQP12A|375318
C190rf75]284369
C30rf79|152118

. |C70rf33|202865
‘ |[C8A|731

. CCDC105|126402
- |[CLEC1B|51266
DEFA4|1669
DMRTB1|63948
DPPAS|340168
DRD3|1814
GDF7|151449

0O 00 0000000000000 oo

Page Layout

Formulas Data Review View ACR( File GO Insert  Page layout Formulas Data Review View ACROBAT  Devel
e,
11 - A- Av = = — | - E@Wrap1 g;z::)y i Calibri P Wrap Text
.~ O~ A - E E Merge Pafte ~ Format Painter B I U-& Merge & Center -
Clipboard I Font M Alignment I
Font N Alignment
P3 - fr | =LOG(B3+1,2)
Jr | =LOG(B3+1,2)
A N 0 P Q R S
0 p Q R 1 Primary Metastasi: Metastasii MetastasiiNormal Norn
Matastas Matastask Matastasi Nor MADi  |AIEV-DSAIAISEORAAISKOGA ATEL.  |aimy
TCGA-BH- TCGA-E2- TCGA-E2- TCE 11R- 11R-A213- 11R- 11R-A12P- 11A-23R- 52R-
A18V-06A- A15E-06A- ALSK-06A-ALE 2 |Hybridization REF = |A12D-0 ~ |Max |~ |07 ~ |A12D-0 - |07 ~ |A12D-0 - |A12C
11R-A213-11R- 11R-A12P-11A . 3 |pTPN20A 653129 0 0.0726| 0.101112 0 0
Max |~ 07 ~ |A12D-0 ~ |07 > A121' Copy equatloj\ CT45A2|728911 0 0.1657 0 0 0
0.0726| 0.101112 0 (optional} |cTasasajaats2o 0 0.1657 0 0 0
0.1657 = 6 [SNORA4|619568 0 0.2651 (] (] 0
7 |SNORA44|677825 0 0284 0 0 0
g:;:iz 2. Arrow appear g AQP12A|375318 0 0.2904| 0.367818 0 0
9 [C190rf75|284369 0  0.2904| 0.367818 (] 0
0.284 10 |C30rf79]152118 0  0.2904| 0.367818 0 0
0.2904 3. Double ¢licks 11 |c7orfa3| 202865 0 0.2904| 0.367818 0 0
0.2904 12 |C8A|731 0 0.2904| 0.367818 0 0
0.2904 13 |CCDC105|126402 0  0.2904| 0.367818 0 0
0.2904 14 |CLEC1B|51266 0 0.2904 0.367818 0 0
0.2004 15 |DEFA4|1669 0  0.2904| 0.367818 (] 0
0.2904 16 |DMRTB1|63948 0  0.2904| 0.367818 0 0
17 |DPPA5|340168 0 0.2904 0.367818 0 0
0.2904 18 |DRD3|1814 0  0.2904| 0.367818 (] 0
0.2904 19 |GDF7|151449 0  0.2904| 0.367818 0 0
0.2904 20 |LCE3E|353145 0 0.2904 0.367818 0 0
0.2904 21 (LOC283999|283999 0  0.2904| 0.367818 (] ([
0.2904 BRCA from TCGA | Sheetl | KEGG ECM RECEPTOR INTERACTION @
0.2904 Ready M

Note: double check several cells to make sure

21



Remove extra spaces within a cell

B3 Microsoft Excel - Book3

@] File  Edit Insert Format Tools Data ‘Window Help Adobe PDF
NEEH RO SRR %G S8 E AR B2 - @ v 10 »| B I U]

Bl v A =TRIM(A1)

A B
Please get rid of  extra spaces |Please get rid of extra spaces

AlWN|—=

22



Color cells with Conditional Formatting
Example 1

EX xlsx - Excel

Mormal Bad Good Neutral |Ca|n:u|atiun

2 Conditional Fofmat as || | Explonatory... |Input Linked Ce Note
Greater Than...
L[> ]
T To
Top/Bottom Rules Less Than...

_| _ —El | Q | R | S 1 T

A~
iH- (==H DataBars k E Between...

L -1

[
IH- L= Color Scales C Equal To...

. _El
R- § Icon Sets r Text that Contains... | log2(M/P log2(P/N
- —-[abl = | Pave *) ~1) *  MvsP.pvalu
-1 F
98 [F Mew Rule... A Date Occurring... 91r53‘35.4‘35 1.144637 0.075121 0.5336991]
82| [ Clear Rules , | B 247 5286.836 -4.4375 -1.10172 0.189681¢
45 E Manage Rules . E?FEJDE‘HJEE -0.25685 -0.08717  0.672425¢
| Duplicate Values... 31’ 2156.754 0.090939 -0.47521 0.896235:
05 5.6343 30.6551 393.215¢ More Rules ?‘Br 350,914 2.315072 -0.01446  0.4437968
55 3491259 331471 2496.964  wreen e 25r3158.4?4 -5.44442  6.569742  0.004309]

23



Color cells with Conditional Formatting

Example 2

Highlight extreme values: Color Scales

b what you want to do... Signin F)‘_

o o ]
) 4 J | €= EX
P e
Cell
Table > Styles = hd hd

o Conditional Format as
Formatting ~

T
Highlight Cells Rules *»

Top/Bottom Rules
ry
-.BH- Data Bars
D1A

E:| Color Scales
0~
923 Icon Sets
923

0 [E] New Rule...

'846 [=] Clear Rules
923 E Manage Rules...

769 231450 v.UJ7o
769  3.3143 0
0 33143 0.6593
0 33143 0
0 3.3143 0.6593
0 33143 0
692 3.3143 0
0 33143 0
0 33143 0
0 33143 0
0 0 0.9889
923 0 0
‘846 1.3257  1.6481
0 0 13185

€2

LE

Insert Delete Format

2 AutoSum ~
Fill -

& Clear~

Cells Editing

»

’ E E E Eim Ave(Meta
E] E E E ~ |stasis) |~ |log2(P/ ~
s’ n 73225 .nA1493
i

Red - White - Blue Color Scale
Mc

Apply a color gradient to a range
y 92U of cells. The color indicates where
.9'2.00 each cell value falls within that
r range.
s0143 0.34___C

3.3143" 0.22717 09172177
3.314370.358175 0.746617
3.314370.354275 0.721067 0 0.345782
3.31437 071.105383" 0.1684 1.074083
3.314370.117925 0.552383 " 0 0.473661
3.3143" 0.113551.088267  0.67365 0.90714
3.31437 0.961571.058517°  1.11 0.069648
3.3143 070.679967" 1.01045 0.748433
3.3143" 070.552383" 0 0.634485
3.368170.504075  0.64965 1.68405 0.04944
3.368170.7031750.192267  2.43735 -0.51452
3.3681" 1.44295 1.915183° 2.43735 0.254962
3.3681:1.542875: 0.21975: 2.0607 -1.05988

142
p19
505
)57

0 0.643761
0 0.362894

A

Y O
Sort & Find &
Filter » Select =

log2(M/P
) e
0.171054
-0.17439
0
-0.30579
0.060058
-0.2745
-0.93901
-0.80456
-0.7833
-0.84955
-0.63448
-0.31931
0.035638
0.259086
-0.63448
0.702252
1.52759
0.23771
1.327276

24



Color cells with Conditional Formatting
Example 3

Highlight extreme values: Color
Scales -> More Rulgs

but  Formulas  Data  Review View ACROBAT Developer Q) Tell me what you want to do

7
e Merge & Center $-% 9 %5 Conditional Formr
Formatting -~ Tat
ont Alignment Number Styles
fe , ,
New Formatting Rule N I X
R S - L
Select a Rule Type:
= Format all cells based on their values
= Format only cells that contain
= Format only top or bottom ranked values
= Format only values that are above or below average
og2( M/P = Format only unique or duplicate values [
- |082(p/E MvsP. = Use a formula to determine which cells to format s
0.384316| -0.34068 0.5€"| Edit the Rule Description:
0.093457) 0.077152 0.64¥ Format values that rank in the: !
-0.30015( -1.06402| 0.54
Top 10 % of the selected range /
0.205713| 0.109701| 0.7§ EI <€ | Top bOttom

-0.97894| -1.33834| 0.1] _
-0.53919| 2.732735| 0.74
0.448461| -0.88095 0.4

0.008764| -0.00214| 0.9¢! [ oK ] [ Cancel ] 25
N ARKaAl -N N74Q24 n 2k S = S——




Ex. 2

1. Drop genes with no expression in all samples

1) Hint: Create another column and name it as “Max” -> use formula to calculate maximum value
for each gene -> Sort data by “Max”
2) How do you easily find out where the non-zero value start?
Hint:
a) Convert values in “Max” column from formula format to value with Copy -> Paste Special -> Values
b) After sorting, with Sort & Filter button to find out the value right above 0 -> Search for this value under “Max”
column
2.  Compare primary tumor vs normal, and metastatic cancer vs primary tumor:
1. Convert values to log2 format:
1) To avoid dividing by 0, you can add 1 to each value
2) Start to get the log2 expression for the top gene in the first patient sample, use our tricks ( see slides)
to fill out the rest of the cells
2. Calculate log2 average for each gene in normal samples, and do the same for primary tumor
and metastasis samples.
3. Calculate log2 fold changes (log2FC) between primary tumor and normal, and between

metastatic cancer and primary tumor, and highlight the log2FC with Conditional Formatting

4, Calculate p-values, find out FDR adjusted p-value with the BaRC web tool
(http://bioinfo.wi.mit.edu/bio/tools/fdr/), and highlight FDR adjusted p-values < 0.05 with
Conditional Formatting.

3. We consider a gene is “differentially expressed” if meeting the cutoffs (FDR adjusted
p-value < 0.05 + at least 2 fold difference). Add two columns named as Sig(PvsN)
and “Sig(MvsP)”, fill in with “y” and “n” to indicate if a gene is “differentially
expressed” or not.

Hint: with “if” plus “and” formula


http://bioinfo.wi.mit.edu/bio/tools/fdr/

Lookup and retrieve data

Microsoft Excel - Microarray_Analysis_data_2 SOLUTION [Read-Only]

@J File Edit View Insert Format Tools Data Window Help Adobe PDF
NEH RO SRV E S n S8 E A E 0 - ©
v @oxumsa&mmcwssz@
| - & —D0 | E | F | G [
1 |Probe fetal_brain_mean adult_brain_mean Prabe fetal brain mean adult_brain_mean
2 |100_g_at 5603044225 7.114704126 1091 _at 8.9835988731 11.39205046
3 [1039_s_at 7.098027859 5.818848604 1160_at 7.845672366 9.368257073
4 |1052_s_at 6.935502676 7.634905024 1039_s_at 7.098027359 5.818848604
5 |1063_s_at 7.177586401 9.29804292
6 (1091 _at 8.983598873 11.39205046
7 |1107 _s_at 6.356422623 8.130576734
g |1115_at 3.554644254 3.593192039
9 |1160_at 7.845672366 9.368257073
10 |118_at 2595289217 8.041784791
11 1194 _g_at 5.287191623 1.79435423
12 [1232_s_at 4.275895519 4.241452629
13 1247 _g_at 5938234238 3.684240951
14 11264 _at 4.638605837 3.465669364
15 [1271_g_at 7.456925352 7.19580788
16 |1346_at 8.146894113 12.06442416

Too complicated?
Try BaRC Submatrix Selector
http://biocinfo.wi.mit.edu/bio/tools/submatrix selector/
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http://bioinfo.wi.mit.edu/bio/tools/submatrix_selector/

Look up values in data list: vlookup

* VLOOKUP(lookup_value,table_array,col_index_num,ran
ge_lookup)

— lookup_value :The value to search in the first column of the
table array

— table_array: The table to search (containing the value to search
for in the first column)

* Note: use “S” to fix the table

— col_index_num: the column number from which the matching
value is returned

— range_lookup:
* True/omitted, an exact/approximate match
* False: an exact match

Dollar sign (S): absolute cell references
28



Ex.3

1. Extract gene symbols from the cells under column “Hybridization
REF”. How do you check gene symbols to make sure none of them
is converted to data format?

Hint:

Copy cells in this column and Paste them next to the rightest column ->
use “Text to Columns” to split cells

2. Use vlookup to get the expression levels of a list of genes, such as
genes in the KEGG_ECM_RECEPTOR_INTERACTION gene set from
Broad's MSigDB.

3. Are any of these genes "differentially expressed" as defined by
1)  adjusted p-value < 0.05
2) absolute log2 fold change >=1
Hint: Use “Sort & Filter” button to quickly narrow down the genes


https://www.gsea-msigdb.org/gsea/index.jsp
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